Back to overview
Downtime

Problems of our Payment Provider

Jan 08 at 03:14am CET
Affected services
Payments

Resolved
Jan 08 at 09:35pm CET

Fastspring finally resolved all payment problems - old orders still need some time to get pocessed correctly.

Created
Jan 08 at 03:14am CET

Our payment provider https://fastspring.com/ has issues in processing some payments - we are investigating the issue and trying to solve it as soon as possible.